About EasyMorph Tutorials & Examples Web-help

PostgreSQL Connection problems

Having real trouble connecting to PostgreSQL. Could anyone some advice please?

image

Not enough information to answer.

What are the connector settings?
Are you using ODBC or native Postgres connector in EasyMorph?
What is your EasyMorph version?
Are you able to connect to the same database from the same machine under the same Windows account from another application?

Hello, thanks for the speedy response. I’m using the native connector in 4.7.2.1, no SSL set, but I have tried using the “SSL mode” and “Required” under custom properties as well - but makes no difference either way. Used the same account / credentials / settings in DBeaver and connected no problem. I’m a little stumped so any help would be very helpful

Did you connect successfully on the same machine where EasyMorph is installed? Because it looks like it’s a network configuration problem on the Postgres database’s side. A connection can be successful from one machine, but not from another.

Also, you didn’t answer these questions:

Are you using ODBC or native Postgres connector in EasyMorph?
What are the connector settings?

Screenshots would be helpful.

Apologies, yes same machine that Easymorph is installed on and am using the native PostgreSQL connector in Easymorph. Here are the screenshots of the connector settings:

Capture1 Capture2 Capture3 Capture

I guess that there has to be a change in PostgreSQL-settings by your database administrator.

If you are using Kerberos authentication, you should change settings as follows:
grafik

Hope this helps.

Kind regards,

Jochen

1 Like

Aha, thank you very much. I will pass this on and let you know if it works. Thanks

Our IT Team said: “I permit the office range but we require using SSL encryption when connecting to the database. We aren’t using kerberos”

Apparently the only condition for access that we impose is the requirement for SSL. The IP address we are connected from is also shared with others who can access the database without a problem so the pg_hba shouldn’t be a problem?

If SSL is required: try the property/value setting like mentioned here: Using the native connector to PostgreSQL in SSL mode

SSL mode = Require

Tried that and now says certificate is invalid. Does that mean we need a new SSL certificate?

I’m not familiar with administration of PostgreSQL, but it seems to me that the issue is with that setting: yes. Either you need another certificate or the entry in pg_hba.conf isn’t correct.
I’m afraid, I can’t help in this matter. I think you should clear it with your administrator of the database.

Regards,

Jochen

To learn more about EasyMorph visit easymorph.com.