About EasyMorph Tutorials & Examples Web-help

Using the native connector to PostgreSQL in SSL mode

The native connector for PostgreSQL doesn’t have a setting for SSL mode, but it can be activated using custom properties:

SSL mode = Require

image

2 Likes

Hi dgudkov,

Thanks for this - we have recently started enforcing SSL connections to these databases.

When I set this custom property, I receive the following error:

Test connection failed:
42704: unrecognized configuration parameter “ssl_renegotiation_limit”

As I’m not specifying this parameter, I guess it’s applied automatically. I’ve read into the error and it appears this parameter was deprecated.

Is there a way around this?

Hi Aaron,

What version of PostgreSQL you are using? You can get the full version with the following SQL command:

SELECT version()

Or you are using Amazon Redshift?

Hi Andrew,

I’m getting same error. I’m trying to connect to Amazon Redshift cluster.

image

Hi Tegshe,

Try to add the following custom property:

Server Compatibility Mode = Redshift

1 Like

Ah - yes, apologies - this was for a Redshift connection. I can confirm the above custom property works, and it doesn’t appear to be an issue for our actual PostgreSQL databases.

The option to enable SSL has been added in the native Postgres connector in v.5.

To learn more about EasyMorph visit easymorph.com.