Post filter "keep only first" is suddenly enabled

Dear,

I have noticed that randomly the post filter “keep only first” is set to enabled al of the sudden on the step “Import from database”. I am using this a lot and within my project I have got multiple instances. So it is really annoying when I am developing the project… and it is a huge risk for going live with this.

Can someone take a look at this please? Highly appreciated.

Kr
Edward

Note:: I am using version 5.1.4

I also notice other problems with this is step.
Now I have got some instances that won’t execute. When I hit the refresh button, it seems to work (I am getting a resultset), but when I try to run the complete project, it fails again.

Kr
Edward

Hi Edward,

We will take a look at this.

Dear,
Thank you for the reply. Highly appreciated.

Now I notice that on a step, that settings are missing (selected columns and the setting remove duplicates). Something is wrong here.

Kr
Edward

Maybe it is caused by the fact that I am running things within modules?
Kr
Edward

No, I don’t think so.

Most probably it’s an artifact caused by recent changes in the Query Editor.

The errors come up randomly, I cannot figure out how to trigger or simulate it. It is like: “hey I have already solved this problem” (and even with the addition “just an hour ago”). I am not touching the steps, or I am not working on the tabpage even, but all of the sudden they are changed by the system. Could be that I am using the “reload and run”?

Kr
Edward

Did you mean 5.1.0.4? Try updating EasyMorph Desktop to the most recent version from our website.

yes indeed, i was referring to 5.1.0.4
Now I have installed the 5.1.1 version.
I will monitor this, if the problem stil occurs I will be reporting back.
Thanks.
Kr
Edward

Strange because I noted that on older versions but the problem is that I can’t replicate. Sometimes, this post filter is enabled and only the first 100 rows are retreived. But I can not say exactly how it’s activated.

Next time when you see that behavior, can you please post a screenshot of the Query Editor window? We can’t reproduce it and I want to make sure we’re looking in the right direction.

Dear,
It is back… on 6 different steps at once :-S

Kr
Edward

Can you please send to support@easymorph.com the following:

Unfortunately I am at a customer that has a very strict NDA, so I am not able to sent any files or logs.
Kr.
Edward

I’m afraid in this case our capabilities to investigate the problem are very limited.

Please provide as maximum information as you can, including:

  • The exact sequence of your actions that preceded the bug
  • Full screenshots of the UI when the error occurred (you can blur/blacken sensitive information in it)

Can not replicate it until now but my guess is that it’s coming from the fact that you have a redundant information in XML :

  • SelectAllRows=“false”
  • Rows Value=“100” Type=“Number”

These 2 information must remain synchronized or you could have a bug. Imagine there’s whatever action in desktop removing “rows” tag but keeping selectallrows=“false” => the effect would be that still the first 100 rows only are selected. Don’t know if it can be that.

Note : during my test I tested the custom sql having zone, and I saw that after I modified it and close the query editor, easymorph did not recognize the modification : apply button is still grayed out. I think it’s an issue.

1 Like

We’ve fixed the issue with “Having”. The updated version is now available on our website.

We keep looking into the issue with “Keep only first rows”.

While we couldn’t reproduce the problem, we’ve made some improvements that should prevent such a bug. The updated version is already available on our website.

I have the same problem now. Though I unchecked the field several times, it always comes back with the following message:

I use version 5.1.1.4.

Can you update to the most recent version?

To learn more about EasyMorph visit easymorph.com.