Invalid format of API key


I am trying to connect to a web data source using an API, by setting up a connect or using the “Import from Web API” action.

The API involves an Authorization header with the API Key string beginning with “api-key=…” however when inputting these header details easymorph will display an error message indicating that the value has an invalid format.

Is there any way I can connect to the source despite the key containing a “=” sign, as this is the cause of the issue?

Hi @orangejos and welcome to the Community!

A key containing the equal sign (’=’) shouldn’t be a problem. Can you post a screenshot of the error?

Thank you!

This is what I come across. Please do let me know if this method is incorrect, I am able to reach the access point using the header-key pair in other tools.

Hi @orangejos
Have you tried to fill properties as shown below?

Thanks for replying, yes I have tried that but no luck.

Could you post a link to the API documentation or send it to the support email?

Something similar here:

if the value of Authorization header contains some special characters like /,:,=, etc.
Just in some headers like Authorization



Please provide a link to the API documentation where the Authorization header has a colon (:) character or special characters ( /,:,=).

UPD I'm curious because the Authorization header should have a special formatting (like described here Authorization - HTTP | MDN).
Most probably, you're trying to use the Basic authorization. However, you must base64 encode the login:password string before setting the Authorization header. Or configure a WebLocation connector.

It is a internal API using HMAC authentication/authorization protocol

It is a internal API using HMAC authentication/authorization protocol

Do you mean SCRAM ( Salted Challenge Response HTTP Authentication Mechanism) ?

It should work.