",hexadecimal value 0x1c, is an invalid character

Hello dears,
I am getting this ‘hexdecimal valuer 0x1c error’,when exporting into excel file.
Can you help me with a solution? I have tried to sanitize my data same as solution in discussion ‘Hexadecimal value 0X0F’, but has not helped.

Thanks in advance,

1 Like

You may try to use replace combined with char(28) which seems to be the character of “file separator”. If I were you I would try first to identify the problematic column and may try to correct the source file consequently, or check with the responsible of this file. You can for example remove column by column until it works which will help you to find the column.

If someone has a good free text editor to propose to look for hexa characters, I’m interested, maybe a plugin in notepad++ ? That would be nice if easymorph could propose this in explorer view.

Hi @zsofi,

I tested the “Sanitize text” action as described in this post with the 0x1c character. And it worked as expected.

Are you sure that your “Sanitize text” action has the correct options selected (as described in the mentioned post)? And the “Export into Excel file” action actually exports the sanitized dataset?

Hello dear Andrew,
this sanitizing helped finally. I have applied all possible options on all columns and then the export was allright.
Thanks for the input. :slight_smile: