About EasyMorph Tutorials & Examples Web-help

Wrong Conversion of csv

Hi,

I have a problem with reading and converting a csv file.
Given is a simplified csv file as shown below (just a field and a corresponding value):
See also attached filewrong conversion.csv (166 Bytes)
grafik

As you can see, the file has a comma as decimal separator, the point is the thousands separator.

Case 1:
The settings in the Import action are:

The result in easymorph is:
grafik
The values (of field “Value”) are automatically converted to numbers except the field with the thousands separator. At the numbers the decimal separator has changed to a point, but for the field with a thousands separator, the behavious is as-it-was (comma as decimal separator, point as thousands separator).

Case 2:
As a workaround, I tried to import everything as text (in the advanced options):
grafik

grafik
In this case, I have the option to remove all thousands separators and replace all commas with points. Then, it would be possible to convert thevalue to a number, but I think, there should be an easier way to handle.

In my opinion, the easiest way would be to get the regional settings of Windows.
Is there a possibility to treat the separators as in adjusted in the Windows settings?

great post, have the same problem over and over again. Data conversion (date, numbers …) cannot be done generically at the moment :frowning:

I think, first thousands separators would be really important.
Import allways at Text and Change all other Types can not be the way

To learn more about EasyMorph visit easymorph.com.