Tutorials & Examples Web-help Blog

Using [] in headers


#1

Hi,
Currently with easy morph is not possible to use [] in the headers due to the formula syntax using it (I assume).

Is there a workaround for this? I use EM dumping files in a software that needs headers in [], without this, I cannot automate fully the process of import/export.

Thank you very much.

best,
Jorge


#2

Assuming that you’re exporting into a text file the solution would be to insert headers that contain [ ] as the 1st line of data and then export to a text file with regular headers turned off. Then effectively, the first line will become the headers.

Example:
forbidden-headers.morph (3.2 KB)

Notice the settings of the export action:

****moved to #uncategorized


#3

After reading your question one more time I realized that column names should be the same, just wrapped in square brackets.

Here is updated example that wraps all column names in square brackets.

forbidden-headers2.morph (3.7 KB)


#4

Thank you very much, I added the CSV extension and it seems to be working great, awesome stuff.

Best,
Jorge