Unauthorized Access Code 401002 error in Server

I am trying to upload hyper files to Tableau Cloud using the "Export to Tableau" option. I have the Connector set up using a PAT. When I run this action in EasyMorph Desktop it will successfully run. When I run the task in EasyMorph Server using a scheduled task, it fails. See the error below:

I'm not sure if this is a problem when multiple "Export to Tableau" actions are run at the same time. I'm pretty sure it is not a problem with my connector because I can connect and run them individually just fine.

Any advice would be appreciated. Thank you in advance.

Hi Jaden,

A few questions:

  1. Are you using the same connector in Desktop and Server? Meaning, is the connector you're using in Desktop provided by the Server?

  2. Tableau PATs expire if not used for 15 days. Could it be that you ran your workflow in Desktop more than 15 days ago?

  3. Do you use the same or newer version of Server compared to Desktop?

  4. Do you get the same error, when you use "Export to Tableau" with this connector only once in a workflow?

We had an internal discussion and figured out the possible cause of the problem.

For now, make sure you don't use the same Tableau connector in more than one action simultaneously. You can use the "Synchronize" action to ensure the ordered execution of actions.

Meanwhile, we'll see on our end if we can make the issue resolve automatically.

Hey Dmitry, sorry it took me so long to see this. I will try the Synchronize action for now. This is good for me to know anyway to order the execution of my actions. Thanks for your help!

Hi Dmitry,

Any update on this? I implemented the synchronized action on all of my EasyMorph projects, and I still get this error from time to time:

Is there any way to skip a failed action and still run the remaining actions? For instance, if my first Export to Tableau fails, I still want to run the rest of my actions in the task. I know there is a retry task on failure option but would this be helpful in this case?

Thanks in advance.

Hi Jaden,

The fix is almost ready. However, since the implemented changes are not trivial, we will be releasing the fix with the next EasyMorph version. It's scheduled to be released in 3 weeks.

This error may also be caused by the simultaneous execution of several projects that use the same Tableau connector. Please make sure that the tasks that give you this error are not scheduled to be executed at the same time.

In order to skip a failed action, you'll have to move that action to a submodule and call that module using the "Call another module/project" action with the Mode option set to "Capture errors and continue".

As for the "Retry task on failure" task option, retrying a failed task may help with this error. But you have to make sure that your projects work correctly when executed several times in a row.


Thank you for this info. I have tried to space out my tasks the best I can, but I will double check them. I will also test out the submodule solution.

I look forward to the next version in the coming weeks.

Thanks again for your help.