About EasyMorph Tutorials & Examples Web-help

Unable to see QMC Qlik Sense Command task

I’m able setup connections to the server which test successfully, however I’m not able to see the Stream Task name as setup by my product team:

I’ve tried setting up the connector with the Host URL as being the server, or the link to the app itself - both of which successfully “Test” - however for both the list of “Run Task” remains empty. Suspect it may be a permissions issue but am unsure.

image

Hoping for some help on what the issue could possibly be?

Thanks,
Thomas

Hi Thomas, and welcome to the Community!

Can you please check if you can trigger the task manually from QMC when logged in under the same user account that was used in the Qlik Sense connector in EasyMorph, and on the same computer that was used to test the connection in EasyMorph.

You also may want to check if Qlik Sense allows the “Read” action for that user account.

1 Like

Thanks for the response dgudkov.

Can confirm this was an access issue - once granted access to QMC I was able to see the tasks.

When I run now I get a “HTTP 403 Forbidden” error however I can see the task is successfully triggering. Not a big issue but EasyMorph does report it as an error.

Cheers
Thomas

EasyMorph can retrieve errors of the QMC tasks it started and show them as native EasyMorph errors, for convenience. For this, after a QMC task is started EasyMorph obtains the log of the started task. It seems like obtaining the log file is not permitted for the Qlik account that you use for EasyMorph.

This topic may have a hint how to enable accessing the task log: Qlik Community: How to allow non-Admin users download task log?

UPDATE

It seems like two more permissions are required:

ExecutionResult
ExecutionSession

See this Qlik support article: https://support.qlik.com/articles/000073218

To learn more about EasyMorph visit easymorph.com.