About EasyMorph Tutorials & Examples Web-help

The Google Analytics connector doesn't work

Giving me issue with configuring the Oauth. Whether or not I do the advance Oauth connection, it comes back to localhost:random port/authorize and says connection refused. I have disabled any antivirus.

Can you please post a screenshot of the connector settings and the error?

image

I’ve also tried it without the custom OAuth app just using the default with same issue.

After I hit the authorize button it opens the browser for me to choose to allow the app access. I choose which account to have access. It then redirects to the localhost error.

Do other OAuth-enabled connectors work (Google Drive, Gmail)?

One case can be the windows firewall blocking inbound connections. You can temporarily (!) disable Windows Firewall to check if this is the case (go to Windows SecurityFirewall & Network protection → click active network name (it should be either private/public/domain) → set Windows defender firewall to OFF)

If that helps, you can add a manual allow rule to the windows firewall, or (sometimes that doesn’t help when specific block rules take precedent over allow rules) pinpoint the exact blocking rule that causes the problem.

To do this, type wf.msc in Windows start prompt to launch Windows Defender Firewall with Advanced Security.

Then, to add allow inbound rule right-click Inbound rules → New rule → pick Port → Next → pick TCP, and in Specific local ports write 7890 → Next → Allow the connection → Next

If that wouldn’t help, you can search for a blocking rule. In the same Windows Defender Firewall with Advanced Security window click Inbound rules and click Action column header to sort block rules to the top of the window. There you can see all existing and active block rules and you can try disabling them one by one to find out who blocks the Easymorph OAuth process.

The third option is to reset Windows Firewall to a pristine out-of-the-box state. This option makes sense only if you already found out that disabling windows firewall solves the problem but for some reason can’t find the exact rule set that causes problems. To do this, you can right-click Windows Start button, pick Windows Powershell (Admin) option and in admin console type
netsh advfirewall reset
command

I have a google drive connector using the same oauth connection working just fine. It’s something about this Google Analytics. I have google analytics enabled for that credential’s project. And like I said, I also did the default without the advanced custom Oauth.

The conversation has been moved into a separate topic.

Did you try temporarily disabling the windows firewall?

GoogleDrive OAuth connector uses a slightly different redirect URL (127.0.0.1 vs localhost in GoogleAnalytics case), and the latter could be broken by a misconfigured windows firewall or network interface renaming. Let’s rule out firewall first, and if this fails you also could try explicitly pointing localhost to IPv4 address 127.0.0.1 by adding the line

127.0.0.1 localhost

to your hosts file %SystemRoot%\system32\drivers\etc\hosts and then flushing DNS resolve cache with ipconfig /flushdns command

Hello @Justin_Grewe, we’ve updated the Google Analytics data connector to use IPv4 OAuth redirect instead of localhost in the version 4.7 build 3, check it, I hope this could be the solution for the issue!

Hey there,
I downloaded the latest version and still getting the same issue (http://127.0.0.1:7890/authorize instead of localhost). I don’t have any Windows Firewall or Malwarebytes or any AntiVirus running. Like I said I do it with Advanced Outh using Client ID and Client Secret, as well as unchecking that box and using the default with same results. If you have any other ideas I would love to try anything. Really looking forward to using the Google Analytics Connector for some critical projects on our roadmap.

Hi Justin,

Try creating the connector on another machine, preferably with Windows 10 or a recent Windows Server. A Google Analytics connector can be created even in the free edition of EasyMorph. Note that you can copy connectors between repositories and projects.

That did it. Very strange as the machine I have used to setup other OAuth like the google drive work just fine on that machine. Anyway, it’s setup so I’m good atm. Thanks for the suggestion.

1 Like

You’re welcome!

To learn more about EasyMorph visit easymorph.com.