Synchronizing license issue

Hi EasyMorph Team,

we are trying to set up an EasyMorph license on a Huaweii Server. The providing server runs on an AWS machine. The initial license assignation worked without a problem. We then had to change the date/time setup of the Huawei machine, as it showed Bejing time. Upon doing so, the license leased from the server was rejected with the following error:

The timezones are the same, but for some reason, the Huawei machine shows 1 more hour compared to the AWS machine.

Do you have an idea of how to fix this issue?



The message you’re seeing is not due to some timezone settings, but because Easymorph detects that there is a large discrepancy in the UTC time on both machines (server and client), e.g. the clock on one machine is really off by more than 30 minutes. This is really a serious problem and besides Easymorph it could interfere with general SSL certificate validation (e.g. basic HTTPS operations will start failing), Kerberos protocol has rather strict requirements for clock skew (5 minutes max if I’m not mistaken) etc.

I would recommend finding out which machine is off and fixing the root problem.

It seems that UTC time differs on the server and client machines.

Use these command line commands to check UTC time and timezone. UTC time must be the same on both sides.

wmic path win32_utctime get *

systeminfo | find "Time Zone:"

Over night it seems to have sorted itself out. There is still an error message, but now the license is activated and I can use EasyMorph. I guess I’ll ride with it, unless it stops working.
Thanks a lot for the tips!

So, it seems that UTC time is something different to the timezone that is being defined by Windows. For as much as I keep adjusting the UTC time, it just seems to jump all over the place, in both machines. Sometimes 1 hour apart, sometimes 2, and sometimes around 12 hours apart. Right now, this is what I see on both machines. The first one, Huawei, should receive the license. The second one is AWS and has the server with the license. Ironically, both have the time wrong. Santiago time would be noon. Not 14.00, not 16.00. Do you have any idea on how to fix this?


Have you tried to set up system time according to this article Set the time for a Windows instance - Amazon Elastic Compute Cloud ?

Your screenshot says that some of the settings are managed by your organization.
Have you installed some MDM software like Microsoft Intune or Windows device management? It’s possible that it could lead to some conflicts.