Stop update process


Once in a while I run into issues where updating a projecting steals all memory resources available.
How do I turn off or stop a running update?

I managed to turn off auto-update while it was running, but the project still updates …


Typically, you just need to turn off Auto-update and it will stop the automatic background calculation. Cancellation should now work for almost all transformations. What transformation kept running and couldn’t stop when you switched off Auto-update?

I can see it’s ‘Call other project’ transformations.

I’ll have a look to see if I can optimize origin projects and get back.



The project causing this was calling another project running iterations, looking through a folder to find the newest file and taking a specific worksheet.

The issue was in the target file - When opening the excel file directly, something went wrong, causing a halt to excel, and having to force close the program.

The issue is not in EasyMorph, except I wasn’t able to stop updating from the project looking into the ‘corrupted’ excel file.


Hi Christoffer,

Is it possible for you to share the ‘corrupted’ Excel file with us? If so - please send it to

We would like to make stopping to work correctly with such files.


Hi Christoffer,

Thank you for the file. It definitely can be labeled as ‘corrupted’ because the target sheet contains a very big number of empty cells, spread in a range of 1,045,980 rows 16,384 columns (with actual data present in a range from A1 to D922).

When EasyMorph imports that sheet, it tries to allocate memory for all the 17 billion cells at once and that’s what steals all the memory resources and can’t be stopped. We are planning to improve Import from Excel and make it stoppable at the stage of memory allocation.

The good news here is that you can import data from that file. You just have to switch to “Load only selected columns” mode and check the first four columns. And then filter out empty rows.

Thank you so much!

I got it working based on your input;
1 update level 3 import to skip first row, so columns doesn’t have headings
2 import only columns 1,2,3,4
3 rename columns to have original column names

The iterations then work without crashing the system :slight_smile:

I hope you manage to improve the Excel-import process, so the process can be stopped manually in the future.


@DKcrm Have you tried to select columns with their original names (without skipping any rows)?


that works as well … :slight_smile: Thanks!