Snowflake connection timeout

Timeouts with following message:

Can you try configuring a 64-bit ODBC Snowflake connection in Windows and then use it in EasyMorph with the “ODBC” connector?

Meanwhile, I’ll ask our development team whether it’s possible to extract more details about the error.

Yes. Have configured already and will use it. With other Snowflake native connectors, I need to use WH name.

FWIW, I tried using these paths also but got same error message:
COMPUTE_WH/PROD_CRM/
COMPUTE_WH/PROD_CRM/PUBLIC

Thanks!

ODBC problems with Snowflake. Set up latest Snowflake driver in system DNS (64-bit). Tested successfully. Accessed through ODBC in Excel, so i know it works. Set up in Easymorph. Tested successfully (see Capture1). Tried to query. Get ERROR [22000] message (see Capture 2).


Hi Rick,

Can you please post a screenshot of your ODBC data source settings and the version of your Snowflake ODBC driver?

As for the native Snowflake connector. I see that the Host field of the connector settings has a slash character. Can you please remove that character and all the following characters (if there are any)?

Removing the slash character worked! :grin:

Removing the slash worked for the native connector. I’m not sure what the problem is for the ODBC. I’m happy to continue looking into it with you if it’s helpful. I already got what I needed with the native version. Thanks again!

The “Bulk export to database” action can only work with Snowflake when an ODBC connector is used. So it might be a good idea to try to make your Snowflake ODBC connector to work in case you’ll need that action in the future.

So if you’re up to it, please post (or send to our support email) a screenshot of your ODBC data source settings and the version of your Snowflake ODBC driver.

OK, here it is. This is latest SnowflakeDSIIDriver. It’s working for Excel, Power BI and Tableau (if I switch from native to ODBC)

Rick, thank you for the screenshots.

I was able to replicate this error.

One of the possible fixes for this error is to fill in the Role option of the ODBC DSN. The specified role should have the privilege to access the specified database.

The other fix is to specify the following properties for the user that you are using to connect to Snowflake:

‘DEFAULT_WAREHOUSE’
‘DEFAULT_NAMESPACE’
‘DEFAULT_ROLE’

You can do this by running queries like the following from the Snowflake console:

ALTER USER user_name SET DEFAULT_ROLE = role_name

Thanks Andrew!

To learn more about EasyMorph visit easymorph.com.