Snowflake Connection failing for user name containing a space

Hi, for reasons I won’t go into my snowflake username for accessing my company’s production databases contains a space–it’s my first and last name, separated by a space. Despite triple checking that the credentials are all entered properly, logins still fail via EasyMorph’s Snowflake connector. My dev credentials do not have a space in the username and that connection works fine in EasyMorph.

Is there some way I can use escape characters or something to have EasyMorph correctly parse the username containing the space?

Thanks very much!

ETA: I tried connecting to the same database using an ODBC connection through EasyMorph and the same credentials (i.e. user name with a space) and that connected successfully.

Hi @modester, and welcome to the Community!

It seems the Snowflake Connector for .NET, used internally by the native Snowflake connector, doesn’t support spaces in a username. At least, I wasn’t been able to find a way to escape such spaces. Is it possible for you to use an ODBC connector instead of the native one?

Thanks for that. Yep, ODBC works so I will go that route.

Cheers!

To learn more about EasyMorph visit easymorph.com.