SFTP File Download problem

Hello Dmitry / Community - I am roadblocked on a problem with downloading multiple CSV (*.CSV) files from an SFTP site.

I have a workflow that has been running and now I get an error. The workflow is shown by:

At first I thought it might be something to do with the connector but I clicked on “configure” and then “test” to make sure the connector can connect to the SFTP site.

The connect is able to connect, as shown by the last snapshot. The connector is configured to use passworded access:

When I execute the action, this is the error that I get:

I contacted the owner of the SFTP site to make sure the permissions were correct AND I can connect/download the files using WinSCP and the same credentials as defined in the connector. The only change between when the workflow worked and now is the file names were changed to put the string “current” in the file name.

I tried creating a new project with a single action (SFTP download) based on a newly connector - thinking that a “clean sheet” start might help.

I did verify I’m on the latest desktop version

I’d appreciate any suggestions / help on what’s causing the issue or how to further proceed.

thank you & regards

It looks like the problem is caused by the long dash in the file name - Windows might not allow such symbols in file names. We’ll investigate it and I or someone else from our team will get back to you.

PS. Special thanks for the very detailed description of the problem.

Maybe you can list the files and see what that looks like.


Hi @LJMiller !

We are currently experiencing difficulty in reproducing the exact issue you mentioned. Could you kindly assist us by providing the precise filename that is causing the issue?

For instance, you can do this by logging into the instance via SSH, navigating to the directory where the files causing the error are located, and executing the command ls > filenames-list.txt.

Afterwards, please send us the resulting filenames-list.txt file.

After further investigation, here’s the update:

  • Dmitry was on the right path with suspect characters.
  • Nick’s suggestion of listing the files was helpful and produced the following list:

I then examined the filenames using two tools (Notepad++ and a webtool), producing the following displays:

NOTE - the “?” inside the black diamond is for a problematic character

There is a “wide dash” between the “PHIL” and “Ent” in the filename that I believe is causing the problem. I have asked the owner of the SFTP site to change the file names. Once that occurs, I will re-check the workflow and let you know. Until then, no action is needed.

I will confirm whether the suspect character is causing the issue and will close the request if the updated filenames fix the issues.

As usual, the support from the EasyMorph team is GREAT! Thank you!

1 Like