Tutorials & Examples Web-help Blog

SFTP connection does not work


#1

Hi,

I am struggling to connect to my SFTP using proxy.

We believe it may be caused by the fact we use a port 990. But I am not sure. I may be doing something wrong. See the print screens.

Any idea what can help?

Thanks,
Milan


#2

Hi Milan,

Can you please check your proxy settings - proxy type and that proxy doesn’t require login and password.

If proxy settings are correct, please test the connection with the Test button in connector’s properties. Will it show you the same error?

Thanks,
Andrew


#3

Hi Andrew,

Proxy does not require login and password.

Using the same settings I have managed to connect there using WinSCP tool without any issues.

Thanks,
Milan


#4

Thanks, Milan

Is it possible for you to test “File transfer” action with the same SFTP server but without a proxy?

If no - can you create a test account for us on that server?


#5

Hi, I will try to access any other place without proxy and let you know. Unfortunately, I am not able to create a test account for you. I know it would be the best. It is a very sensitive folder. I will come back to you. Thanks, Milan


#6

Can you please make screenshots of or all the settings for this connection in WinSCP and send them to our support email? It’s possible that our connector is missing some important setting.


#7

Hi,

I have good news. If I connect to that SFTP without proxy then it works well. Unfortunately, I can only do that outside company network. At least we know that the proxy setting is the issue. See the attached print screens from WinSCP.

Thanks,
Milam

WinSCP1 WinSCP2


#8

Hi Milan,

We have slightly updated connection error messages. Please update your EasyMorph Desktop to the latest version from our download page (http://easymorph.com/download.html), then try to connect with the same connector again and send us a screenshot of the error message.

Thanks,
Andrew


#9

Hi Andrew,

Thanks for your assistance. Here is the new error message.

error%20v2

Thanks,
Milan


#10

Thanks, Milan

Thank you for the screenshot. Unfortunately, it only tells us that we should look for clues elsewhere.

Can you please try to connect through WinSCP with “Do DNS lookup at proxy end” option set to “No”. Will it give you an error?


#11

Hi, it still connects to the SFTP. Thanks, Milan


#12

I have not mentioned it is the protocol SFTP-3. Not sure if it helps or not.


#13

Does you proxy support HTTPS? If yes - you can try to connect from EasyMorph by setting “Proxy type” to HTTP and “Proxy port” to an appropriate HTTPS port (usually 8080, 3128 or 808).

Also, can you tell us which proxy server software is used to run your proxy server?


#14

Hi, I am not sure it supports Https. I have tried many combinations and none of them has worked. Thanks, M.