Scheduled tasks not running from Server

Hi Dmitry, all,
I’m facing a scheduled task issue. I have about twenty tasks that are scheduled on an EasyMorph Server environment, at various frequencies (every 4 hours, Every day, etc.)

The screenshot attached illustrates my issue:

  • On the Task tab, Status, I see my list of Tasks. The Status column indicates a ‘Next run’ that lies in the past, e.g. “Next run 6/10/2021” while we’re already October 8.
  • Looking at the Logs, I see that the tasks have not run. Also, the target systems were not updated, automatic mails were not sent,… so I think the tasks have effectively not run.
  • When opening the task, and re-saving it, the issue seems fixed.

I have a gif illustrating the point above, but as it contains sensitive info, I’d rather not share it here.

As per the last bulletpoint above, I have a fix for now so it’s not blocking. But is this somehow a known issue, or am I doing something wrong? Is it relevant to provide system (windows event) logs?

Hi David,

Can you please do the following:

  1. Restart the Server
  2. Send the debug logs located in C:\ProgramData\EasyMorph Server\Logs\Debug log to our support (

Hi Dmitry,
Thanks for your reply.
I have sent the requested info. I’ll reboot the server asap, but this will need to wait until the end of the working hours (I’m at UTC+2).

Thank you for sending the logs.

06/10/2021 09:00:48    027546 DEBUG     TaskAccess 'Disabled'

It looks like on October 6th you changed space security settings and disabled tasks for this space. Disabling tasks hides them from users, but also prevents tasks from execution. If you want to hide tasks from users but keep them running on schedule, move the tasks into another space where users don’t have access.

Restarting the Server (my initial recommendation) won’t help in this case. Tasks should be enabled in order to run on schedule in that space.

Hi Dmitry,

many thanks! Indeed, the setting was erroneously changed. I guess what got me confused was the ‘Task editing’ label. While the explanation on the right is clear (i.e. tasks are disabled, so both their editing and running), my simple interpretation of “Task editing = disabled” does not necessarily imply the tasks won’t run anymore.

I have reverted the setting and believe this should fix it. If not, I’ll post an update soon.

Thanks again, and KR

Good point. We’ll make the labels less confusing.

I think you want to use this option: “Task editing=Lock project”
Admin can continue to manage tasks. User can run tasks but can’t modify them.