Run external program not showing anything on screen


Hope you are well.

I have an exe file that I need to run in order to download data from a website. The exe file is a python file that has been packaged. It uses the Selenium testing framework in order to login to a website and download a file.

When I run the program outside of EM, it runs perfectly and I can see what is happening on the screen.

However, when I use the Run Program command on EM, it does not show anything on screen. I waited several minutes and nothing shows in the location where there should be a file downloaded.

This is how my task looks:

Am I doing something wrong?



Hi Shaheed,

What happened when you started that action?

It it possible that your program just waits for user input?

Nothing happened on screen. It could be that input is required. I also tried specifying that in the action.

I have sent the program to you on your support email for you to take a look.


I managed to resolve the issue by specifying parameters as follows:

Thanks anyway.