Problem creating OAuth configuration

Hello

I am trying to configure an OAuth connection within ‘Web Location’. The end-point is documented to a limited extent here: http://63.33.76.153/Help/Api/POST-OAuth-token

I have found a few limitations so far that hopefully can be worked around with a bit of advice:

  1. It uses POST rather than GET. When I click to Authorize within EasyMorph it seems to send a GET request as the error returned is “The requested resource does not support http method ‘GET’.”.

  2. It uses ‘Password Grant’ OAuth Grant Type. In a different API connector I have to pass the Client Id, Username and Password but in EasyMorph I can only see an option to pass the Client Id.

Any help much appreciated!

Thanks

Hello!

I was unable to find any documentation regarding this service. But, as of now, EasyMorph does not support password grant type / resource owner password flow.

1 Like

Thanks for the info olysak.

It would be good to know if this change to the OAuth is on the roadmap of future developments.

Actually, it looks like you don’t need full-blown OAuth at all in this case. You can use Web Request action to make first POST request to the oauth/token endpoint, then use Return response body as action result option, parse received body as JSON and pick access_token field. I can’t find any documentation regarding this Telematics service, but if this is in some way compliant with OAuth, you then should use the value of this access token in subsequent actions.

I believe similar approach is described here:

2 Likes

Thanks very much for the solution. That is working well.