About EasyMorph Tutorials & Examples Web-help

Powershell_Cannot run the macro error

Hi team,
I have 1 .xls file, which I want to save as .xlsx through a macro and then import this file into easymorph project(and do some transformations).

To call the macro, I used Powershell, which I found in another topic.
Unfortunately it brings me the following error: ‘Exception calling ‘Run’ with 1 argument: Cannot run the macro, the macro may not be available in this workbook or all macros may be disabled’.I checked my macro file again, the macro is there, the name of the macro has been copied so should be correct and all macros are enabled.

Attached sending picture of the powrshell and also the error.
Could you please check and help me?

Thanks in advance,
KInd regards
Zsofi

Hi Zsofi,

Can you please try to run that PowerShell script in the PowerShell console or PowerShell ISE. Will it give you the same error?

Hi Andrew,
tried as per your advice, but receiving the same error.
I don’t understand what could be the root cause.

The role of that VBA macro is to open an .xls workbook and save it as .xlsx.
Then closes excel.

Do you have any idea?

Thanks and regards,
Zsofi

Hi Zsofi,

Since it’s not an EasyMorph error, it’s out of the scope of our support.

But you can try to google the error message. Most likely it will give you a solution to this issue.

To learn more about EasyMorph visit easymorph.com.