About EasyMorph Tutorials & Examples Web-help

Possible bug export to excel with multiple sheets


#1

Hi

When I export data to an excel creating multiple sheets (3 export action one after the other) and I run it until the second export action (second sheet) it says that when I run the second action again, that de file does not exist yet but the file realy exists.

I also get an error when running this on the server. It could be the explanation for the error I get on the server.


#2

Hi Nikolaas,

Can you please send me screenshots of the properties of all the three Export to Excel actions.

Also, you mentioned that error appeared when you ran the second export action, but you screenshot shown an error from the third Export to Excel action. Can you please clarify that.

Regards,
Andrew


#3

Hi Andrew,

I have tried to make a reproducible example.

  1. I import an excel sheet

  2. I export this data to 3 sheets. I am exporting in the “overwrite” mode.

When I run it for the first time, all works wel. Then I select the second export action and klik run action and then it fails. It is a bit weird that I have the problem on the server as well because the Excel file I create there has always a unique filename because I have integrated a timestamp in the filename. I am also exporting in overwrite mode in that project on the server.

bug.zip (13.9 KB)


#4

Nikolaas, you getting this error because overwrite mode only affects first “Export into Excel file” action (and it affects the whole file, not a separate sheet). And when you run the second action for the second time, only that action is being executed. So target file still contains Sheet2 sheet which was created by the initial execution of that action. Hence the “Sheet already exists” error.

As for the “File not found” error - it’s a different error. Please send me more details on the project which raises it.