Permission denied (public key)


I hope you are well.

We are seeing this error "Permission denied (public key)"
Location: action "File Transfer", module: Main, table: Test

We are using ssh to connect to the winscp ftp. This works fine from the desktop but keeps failing on the server. It works fine from the desktop. I even checked the connection by clicking on 'Test' and the test was successful.

Could someone please help me understand what the issue is and what we can do to resolve it?

Thank you

Which version of Server and Desktop are you using?

Maybe you're using a newer Desktop version supporting updated host key algorithms.


Thanks a lot :slight_smile:

Ok I have checked the settings on our end and downloaded the exact same version as the one on the server on my desktop and ran it again and it worked.

So the project with the version on the server fails but works with the exact same settings from the desktop.

Thank you

Do you mean that you've downgraded your Desktop to and can still connect to sftp ssh?

Make sure that :

  • The server IP was added to the SSH server allow list.
  • The SSH user access is not limited by IP or directory.
  • You're using the same private key, user name, host, port, etc, for the Desktop and Server.

Also, try to connect via 3rd party utility from the Server using the same settings you use in the space connector.


yes that's right. I wanted to check if I am able to connect via desktop using the same version and it worked.

I will check the other points you have listed.

Thank you once again for your kind help. Really appreciate it :slight_smile: