About EasyMorph Tutorials & Examples Web-help

Number format - problem when pasting from clipboard


#1

Important: we use European number format.

While testing we often copy data from Excel using the clipboard. EasyMorph doesn’t take ‘,’ for a decimal separator. Therefore 10,87 leads to 1087.
I don’t see where to set the number format in EasyMorph.

Is there a workaround?


#2

Hi Michael,

Unfortunately there is no simple workaround for this problem.

It’s possible that we will be able to use decimal separator from the system settings for pasting data from the clipboard.
We will get back to you after some tests.


#3

Michael,

It appears that making EasyMorph to use decimal separator from the system settings without breaking internal copy&paste action not as simple as we thought.

So we decided to add “Decimal separator” setting to Input and Sandbox transformations as a quick workaround. It will be available in the next minor release.

We a planning to thoroughly address this problem in one of the next major releases.

Thanks,

Andrew