Missing diacritics when exporting to database

Hi there,

I have a issue with missing diacritics when exporting to database.
Using MySQL connector
My database have UTF8 collation

In EasyMorph I have “Tričko” but after export I can see in my database just “Tricko”.
Some other words works fine, for example “Náramek”

There is copy of SQL Insert from my server:

You can see difference between “N%C3%A1ramek” and “Tricko”.

How can I fix this?

Hi David, and welcome to the Community!

Which MySQL version, EasyMorph version, and connector type (native or ODBC) are you using?

If it’s an ODBC connector, which ODBC driver version are you using?

I tried to replicate this issue on our test MySQL server, but it worked correctly with a table with the utf8mb3 charset and the utf8_general_ci collation.

Hi Andrew,

MySQL 5.7.36
connector type is native

I did some more tests and I can see this:
EasyMorph connects with latin1 encoding and there is bad diacritics in SQL

2023-03-13T10:43:07.924086Z 11492061 Query SET NAMES latin1

2023-03-13T10:43:13.173979Z 11492061 Query INSERT INTO reporting.rg_product (reference, name, type, youtuber, price, commission, supplier, description, delivery_date, service_factor, combination_id, purchase_price) VALUES (‘T00281XL’, ‘Detsk� mikina SirYakari UHC [XL]’, ‘Tricko’, ‘SirYakari’, 100, 200, ‘JimiPrint’, ‘Mikina’, NULL, 1, 4, 1.00)

You can try to set the encoding of the connection in the connector’s custom properties:

I was able to replicate the issue by setting the CharSet property to latin1. Also, I made sure that it works correctly with the utf8 charset.

You are my hero! :slight_smile: Works perfect, thank you

You are welcome!