Matching Database Rows Issue

Hi guys and happy new year!
I was so excited about your latest update (today I tried to install EM 5.6.2) that I tried to install it and tested it on some of my projects to see if there were any problems.

Unfortunately I noticed something a little annoying about the behavior of the action in question, which creates a bit of problems for me. Now I'm using EM

As you can see from the following attachment, I have a starting table that has a certain set of data... this table can sometimes happen to be empty.

After the matching database rows action, the schema changes, so that, if in other derived tables in which I carry out a merge operation to perform other operations referring to the current one, the merge action does not give me an error because as output (from matching database rows) I have the structure I select from the database.

Using the new version instead, if the starting table for which I have to do a matching database rows is empty, this action returns the error: object reference not set to an instance of an object.

I also tried to put a block that skips the action when the previous table is empty, but I need the database structure otherwise all the merge actions that I cascade on the project fail.

Is this all desired behavior or can I hope you correct the problem? :slight_smile:

Thank you!

Hi @carlo.nigro,

Happy New Year to you too.

We were able to replicate this error and are planning to fix it shortly.

1 Like

@carlo.nigro, the bug was fixed. You can get the updated version from our download page.

Hi @andrew.rybka ,
I can confirm that the issue was solved.
Thank you!

1 Like