LocalService Account Access Permissions

I’m trying to apply the License Key to my Server installation, I’m using Windows Server 2019 running in a GCE VM. Every time I try to click “Proceed” I’m told that the folder cannot be accessed. The documentation mentions this but it’s not explicit.

I’ve tried to figure out how to give permission to the LocalService account but I’m unable to figure out how to do that.

Is there a clear/explicit set of instructions on how to give access to the Service Account?

Hi @beerye3 and welcome to the Community!

Open properties of the folder where the license key is saved.

  1. Press “Edit” to edit folder permissions.
  2. Press “Add” to add a new permission

When adding a new permission:

image

  1. Type in “LOCAL SERVICE”
  2. Press “Check”. Notice that LOCAL SERVICE becomes underlined - it means the account was found.
  3. Press OK

Make sure that LOCAL SERVICE now appears in the list of accounts that have permission to read the contents of this folder.

image

  1. Press Apply

Thanks Dmitry

I had already figured out how to add the permission, and I had tried several different locations but was still having the access denied error.

I’m not sure what the distinction is between ‘Upload’ and ‘Browse’, but I was able to just get it working using the ‘Browse’ option, whereas Upload was not working.

Thanks!

You’re welcome!

What EasyMorph version do you use? We will check again if the “Upload” option works correctly.

I believe this is the latest version, v5.1.0.6, according to the Server Monitor.