About EasyMorph Tutorials & Examples Web-help

Iteration Error - Input Table or transformation is not defined


#1

I have a process that is the combination of two projects: one is the parent with an Iterate transformation, and one is the child with the transformations to apply to each file.

The child project works on a given file, but when I run the parent process I get the following error:

Input table or transformation is not defined. Check properties.

I’m using the List of Files transformation to generate a list of file paths to assign to the parameter in the child project so I don’t see how the input isn’t defined.

I’m finding it difficult to debug this problem.


#2

It looks like in the child project you have a transformations with 2 inputs (such as Append or Merge) and the reference to external table in that transformation is broken.

Can you please check the child project and see if all 2-input transformations have correct references to tables.


#3

Also, if your child project works but iteration doesn’t, make sure that the child project is saved before running the iteration.


#4

Yes, you’re right, it turned out that in the child project I had some tables off screen (needed to scroll to them) with broken transformations and that were completely disconnected from the output. That’s why it appeared like the child worked even though there were errors in the project.

It works now.

Thanks!


#5

You’re welcome!