Issues with Running External program

In my example I am just running the cmd.exe and doing a copy of a file from one location to another on the same box.

If I run the script (cmd) on the server it works fine. However when I run it via tasks it seems to run forever and doesn’t error out but also doesn’t complete the task.

Does the Server account have access permissions for the folders mentioned in the command line arguments?

As in the windows user logged in can read/write/access that folder?

Ahh I think I see what you mean. If I try to create a new “space” in that area it says access denied.

Are you aware of how to work around that?

Give the server account (by default it’s NTAUTHORITY\LocalService) read/write permissions for the folder. By default, the NTAUTHORITY\LocalService account can’t access Windows users’ folders.

That did it. Thank you sir!!

Nice to have would be an error on that indicating a permission issue on that step.

Unfortunately, we can’t do much in this case because the problem is encountered in an external program (in this case xcopy), not EasyMorph. Sometimes checking “Capture output” helps identify error, but it depends on the called program logic.

No worries! Thanks for your help. Consider the question closed.