About EasyMorph Tutorials & Examples Web-help

Infrequent error: HY000

Hi Everyone,

I am experiencing an error that occurs 2 out of 3 times when trying to refresh my table list in my connection to a DB2 database.

Context: EasyMporph is installed in an AWS Workspace, hosted in Virgina. The DB2 Instance is sitting on a server in Chile. I am accessing the DB with the EasyMorph connector. It used to work fine for about 2 months. During this week I have automated logics failing. One out of two types of error message appear:

ERROR [HY000] [IBM][System i Access ODBC Driver]Error in host server data stream
ERROR [HY000] [IBM][System i Access ODBC Driver][DB2 for i5/OS]

When I manually run the logic, these errors happen 2 out of 3 times. I have not been able to detect any issue that could explain this problem. When I run the same logic from a local machine, it works fine.

Could you please help me with ideas of how to manage this issue?

Thanks in advance!
AlbertImagen2 Imagen1

Hi Albert,

It doesn’t look like an EasyMorph error. I would suggest updating your DB2 drivers and re-entering credentials in the ODBC driver.

Hi Dmitry,

thank you very much for your quick response. We did as suggested and updated the ODBC driver. In addition, we enabled the “Capture Errors and Continue” options of the action “Call another module/project”. Tonight, all but one modules worked fine. One module however did not go through with posting required data. The Launcher did not trigger an error. The logic itself showed an empty error log (see screenshot).
Manual refresh of tables in queries still shows the error mentioned above in 2 out of 3 cases.
On a local remote machine, this error does not happen. Our ping from the AWS Workspace is around 130, vs 30 on the local remote machine.

Is there maybe a possible fail/safe function you might recommend using within the EasyMorph logic?

Thank you very much again for your help.

Best,
Albert

I still don’t see any signs that the error is produced on the EasyMorph side. Try contacting DB2 support / community.

To learn more about EasyMorph visit easymorph.com.