Import txt delimeted file with custom separator

Hi there , I want to know if Easymorph can manage custom separator for delimited files , we are using this simbol “¦” , I search the options but not find this special caracter.

Let me know if there is something to manage this situation.

Regards
Eduardo

Hi Eduardo and welcome to the Community!

The “Import delimited text file” action doesn’t support arbitrary characters as a separator. As a workaround, you can try the following:

  • Import your file with the Separator option set to “No separator” and the “Ignore quoting” option from the Advanced options checked.
  • Use the “Table-wide replace” action to replace the “¦” character with some other character (or set of characters) that can be treated as a separator by the “Import delimited text file” action. Please make sure that the chosen character is not present in your delimited text file.
  • Use the “Split delimited text into columns” action to split the imported text into columns.

Great advice Andrew it works flawlessly , I change a little the solution , for the final part after change the caracter I exported the file in a new csv file and then re-imported.

Thanks a lot.
Regards
Eduardo

To learn more about EasyMorph visit easymorph.com.