About EasyMorph Tutorials & Examples Web-help

Import from Web API error

Hello,
I have recently updated to Desktop version 5.1.1.1. Now my ‘Import from Web API’ has stopped working.

So the connection is set up as a ‘Web Location’ with ‘Basic’ Authentication. It used to work fine. Now when I run the ‘Import from Web API’ action, I get the following error:

Error: Server returns non successful status code: 401 (Unauthorized)
Source: action “Import from Web API”, table "Test Extract"

If I run the same API call using Postman (with the same credentials) it works fine.
Projects that use this connector also run fine on EasyMorph Server.

It has only started happening on Desktop since I upgraded to 5.1.1.1. Is this bug?

Regards,
Mat

I’ve just re-installed Desktop 5.1.0.8 and the ‘Web Location’ with ‘Basic Authentication’ works, so it must be something in 5.1.1.1 that is causing the issue.

Hello Mat and welcome to the Community!

We’ve made a change in v5.1.1 in the way Basic Auth works in the Web Location connector. So yes, it works differently.

Try enabling/disabling the “Pre-authenticate each request” option in the Web Location connector (shown below).

image

Hello Dmitry,
I’ve tried this but it still doesn’t work. I tried setting up 2 new 'Web Location’s, one with ‘Pre-authenicate each request’ ticked and another unticked. Both error the same way.

Regards,
Mat

I am encountering a similar issue. Some existing Web Location Connectors that worked under 5.0 do not work under 5.1.1. The Web Location Connector giving me problems uses Basic Authentication. Switching back to version 5.0 of EasyMorph corrects the issue. Re-creating the Connector under version 5.1.1 of EasyMorph did not fix the issue. Also, running with “Pre-authenticate” set or un-set does not correct the issue. Ideas?

Use version 5.1 for now. We’ll investigate what’s going on with 5.1.1.

2 Likes

Could you please do the following steps:

  1. Set Authentication to None in the data connector.
  2. Configure Web Request action to use the same data connector, HTTP method, and URL.
  3. Add columns with repose code and headers to the response
  4. Run Web Request and send us the content of the WWW-Authenticate and Response-HttpCode columns.

Hello,
Here’s a screen shot after doing as requested in version 5.1.1.1.


There isn’t a WWW-Authenticate column

1 Like

We’ve updated version 5.1.1. Can you please try the updated version and see if the problem is now resolved?

Hello,
Just installed Desktop 5.1.1 build 2 and it work fine now. Thanks.

Is the server version also fixed?

Thanks.

Yes, the Server has also been fixed.

1 Like
To learn more about EasyMorph visit easymorph.com.