Import Excel : Column names in a pivot table


I try to import data from Excel Pivot Table.
Top of Pivot Table, I have formula to calc header name. These data are date made to import in table.
When EasyMorph read Excel, column name are imported in integer not date (The exact opposite of the problem I usually have).

test.xlsx (22,7 Ko) test.morph (2,9 Ko)

This is not exactly the file I am using. I have copied the data from the table but the formula to calculate the title is correct.

As I can’t find how to change the header format in EasyMorph, I can’t find a solution.
If I import by indicating that there is no header, I can’t modify format of column because data format is integer.

How can I do ?

Hi Florent,

The solution is to unpivot the table, format headers, then pivot back with the “Preserve formatting” option checked.

See the updated example below.

test.morph (3.7 KB)

I understand how it works. I did not know these functions.
The end result is close but not exactly what I need.

Here the date format is with “.” and not with “/”.
Result is not the same and can’t be imported in Nav as is. I can change it with replace.

Swiss date are not available.


My colleague found another even simpler solution.
By changing formula to calculate text in Excel issue is solved.

1 Like