About EasyMorph Tutorials & Examples Web-help

Import CSV: textfield imports as number error

Hi,
We try to import a CSV file with data and text, separted by semicolon. In CSV file the data we want to import is between double quotes, but after import the data(text) is set to number.
Changing setting comma/point as groupseperator is noit the solution.

Help is appreciated?

Hi @MODH and welcome to the Community!

Try changing the decimal separator to comma. See below:

image

Hi @dgudkov ,
this option only change the comma to a point and we need the text as a comma for validation in a database in a complete other process.
We also thought about this and than change the point into a comma again, but then it destroys all other textfields in this column.
We also tried all other options like changing the encoding.
I think this is a bug in the import action. In the csv it is marked as text and should be handled like that.

Is it a possibility to add the feature ‘change column setting at import’ ? in this action?

We’ll see if we can offer a fix.

Meanwhile, you can use multiple conditions to preserve other values from being broken while replacing the dot with comma, for instance:

if(isnumber([Data]) and contains(astext([Data]), '.'), replace([Data], '.', ','), [Data])

@dgudkov Thank you for the response.
The provided (temporarily) solution does not work for us, since we have more data that needs to stay as is and no replacing.
Hopefully development can fix the import issue

@MODH,

we’ve added a new option in v4.4 that regulates how numeric values should be imported in the “Import from delimited files” action. Version 4.4 will be released in a few days.

image

Thanx, that is a great solution

To learn more about EasyMorph visit easymorph.com.