I would like some tutorial, with steps from beginning to end, how to use Microsoft Sharepoint in Easymorph

I am new to Microsoft Sharepoint and I would like an easy tutorial showing the setup and use of Microsoft sharepoint.

Hi @easymorph1,

Can you elaborate a bit, please? What would you like to see in such a tutorial?

The set up of the sharepoint connecter. Then the download of the required file from sharepoint, using the file and putting it back.I am currently having trouble with the connector. Getting errors.

I am new to Microsoft Sharepoint and I would like an easy tutorial showing the setup and use of Microsoft sharepoint from within EASYMORPH. If there are permissions, what has to be set up to get the sharepoint connector to work?

I am not understanding the terminology and process to link EASYMORPH to SHAREPOINT. Below is the SharePoint setup.

You can see that 6 users have authorized access, including the USER EASYMORPH, which is the user that the easymorph software is licensed to.

I first set up a CONNECTOR. See below.

I then authorized the connector.

And pressed the test button to try it.

I now assumed that I must inport the SHAREPOINT Source list to get the sharpoint file, but I get an error.

So how do I read or download or import the SHAREPOINT file?

That I why I am asking for a tutorial that shows the procedure and flow. Thanks.

Hi, you may not use the good action. You are trying the “import sharepoint list” action. A sharepoint list is equivalent to a table in sharepoint. If you want to download a file from sharepoint, simply use the “sharepoint command” action, for example available in easymorph

Thanks for the answer. I corrected the project and get a different error.

I am not sure what the LIBRARY field should be. My first action lists the correct filename from the connector. When I try to download that file to the CC: drive under the folder documents (2nd action), I get the error.


Can you also show us the screenshot of how your second action is configured ?

There might be a bug at least in the error message as it’s not a list that is searched but a file.

Attached is what you requested for the second action.

Hi: I am getting very frustrated in trying to use EASYMORPH to make a connection to SHAREPOINT. It is almost two months since I brought up the topic. I have made some progress but I am still getting errors. Here is what I have successfully completed.
I set up the connector to SharePoint and authorized the user ID that signs into the EasyMorph desktop computer. I tested the connection and it works.

As suggested in the documentation to use SharePoint commands, " The easiest way to build a list of remote files on a SharePoint site to be downloaded or deleted is to use this action in its File list configuration, including the “File name with full path” option. This list can then be modified to generate the final list of files to be downloaded or deleted." So, I did the list files command. See the table actions:

That command worked and the file I want to download is in the list in the 1st column.
I now want to download the SharePoint file to a local folder. I used the command “Download File” BUT now I keep getting an error when I run the action. WHAT AM I DOING WRONG? See 2nd action.

But it does EXIST because the 1st action finds it. Here is a screen of the documents in SharePoint.

Please see if you can help or create the tutorial or example. Thanks

Hi @easymorph1,

We will reach out to you by email soon to help you with the issue.


You missed the library value. Between the first screenshot and the second one you changed the value. First you are listing the file inside the “Documents” library, so then naturally you should download it from the Documents library. But you have put the file name with full path inside the library property. It has no meaning to me.

Sharepoint actions are working like a charm I must say. I’d so much like a “copy file” or “clone file” in the command list also :slight_smile:

1 Like