Help needed - Error Authentication Token

Hi everyone,

as of 2 weeks ago, several logics across different setups are consistently throwing the same error. All are targeting Snowflake, but different instances. I suspect it’s a Snowflake issue, but I am checking all bases. Is this something that might be related to, or could be fixed with, EasyMorph?

“Error: Authentication token has expired. The user must authenticate again. SqlState: , Vendor Code: 390114, QueryID:”

I’m not omitting anything. No query ID, no SqlState. And it just popps up randomly, across the board. I tried to include connection parameters to keep the user session alive, and increased the heartbeat rate. To no avail so far.

Any help would be much appreciated!

Hi Albert,

Have you updated EasyMorph recently?

Hi Andrew, yes, to the latest version that is currently available. I don’t have the exact date, but it roughly started around the time I updated the different environments we have. Should I try with a previous version to see if the issue still persists?
Best,
Albert

Yes, please check if the previous version gives you the same error.

In version 5.3, we updated Snowflake Connector for .NET, used internally by EasyMorph to work with Snowflake.

Hi Albert,

It seems that the source of this error is a bug in Snowflake Connector for .NET library, used internally by EasyMorph. We updated that library to the most recent version which has that bug fixed. You can get the updated EasyMorph version from our download page.