About EasyMorph Tutorials & Examples Web-help

Failure Sending Mail. Unable to read data from the trasport connection: net_io_connectionclosed


#1

Hi -
I just downloaded 3.7.1.22 and I’m seeming to get this error on each time I try to setup an SMTP connection. I’ve used sendgrid as well as gmail with the same results.

I assumed it was just the test connection but when I attempted to use the sendemail transformation it ends up giving a generic failure message

screen attached


#3

Try port 587.


#4

We have the same issue when connecting to Exchange SMTP. Tried on ports 25, 465 and 587 - Port 25 is the only port that tries to make a connection. All other ports fail with “Unable to connect to remote server”. We have other clients such as SQL DB Mail and Tableau server which are able to connect fine on port 25… I think this may be due to our SMTP mail server running a self-signed SSL certificate??


#5

I tested it once more and confirm that TLS + port 587 works with GMail.


#6

Most probably, yes. Currently, downloading a file over HTTPS from a web-site with a self-signed certificate produces a similar error in EasyMorph. We’re working on enabling self-signed certificates for downloading files and will also see if we can enable them for SMTPS as well.


#7

@danielhitch,

Can you please download and try the updated version (3.7.1.23). It should now work with SMTP servers with self-signed certificates.

Thanks.


#8

Same issue. Maybe it wasn’t the self-signed certificate after all… :frowning:


#9

@danielhitch,

Does the server has a web-server that uses the same self-signed certificate? If yes, can you please try downloading a web-page over HTTPS from that web-server using the “Download file” transformation? Just want to make sure that it doesn’t fail because of an SSL error.

Thank you,

Dmitry


#10

I understood that your Tableau Server successfully connects to Exchange over port 25. What happens when you try to connect from EasyMorph to port 25 with disabled SSL?


#11

Hi Dmitri,

Apologies for the delay! I have just tested this, and it still fails :frowning:

Daniel


#12

Hi Dmitri,

I have just tried upgrading to the latest EM release and still no joy. Not sure if this helps but, I have managed to connect successfully to our mail server with a PHP connector that we are using for a project using the following options:

ssl verify peer = false
ssl verify peer name = false
ssl allow self signed = true
smtp auth = false

Any chance these options are available in the library that you are using? Could these options be made available in EM Desktop GUI?

Daniel