Excel not importing correctly


We have to download a file regularly but the Excel is not importing correctly.
It’s in the old excel format and can only be downloaded in that format. We do not want to manually save it to the new format to avoid problems…
The file is added as attachment.

Could you have a look at this?

zipcodes_alpha_nl.xls (229.5 KB)

Hi Nikolaas,

It seems that metadata of that file stores an incorrect data range.

Here is a workaround for this issue:

  • check “Do not automatically offset imported range” option in “Advanced Options”.
  • Add additional actions to remove the empty column and the empty row.

Hi Andrew,

So this is not a problem of EasyMorph but a corrupt excel file ?
If so, I will contact the supplier of the dataset.

Kind regards,

Nikolaas, the file doesn’t comply with Excel File Format.

Dimension record of the worksheet states that first used column is B but column A contains data too.

Excel automatically adjusts dimension record when worksheet in being opened, but EasyMorph doesn’t try to do that because of performance reasons.