Error: Get list failed. Unable to open database file

I am in the Connection Manager in EasyMorph Desktop trying to use the "Server Space: Default" option for connections. I keep getting the error message "Get list failed. Unable to open database file." I have restarted the service and I redid my connection to the server but I still get the same error.

Any advice would be appreciated. Thanks!

Hi @Jaden

Please make sure that the server-side connector repository file listed in your Space settings is neither unavailable nor locked by some other process.

The connector repository operates upon a file-based SQLite database. If this database file is not writable, or if it has been locked, the Server won't be able to perform the necessary operations. To examine your Server repository:

  1. Log in as an Administrator to the Server.
  2. Navigate to 'Spaces'.
  3. Select your specific space (usually 'Default').
  4. Proceed to the 'Repository' tab.

Here you will find the path to the repo.sqlite file. Make sure that said file exists, that the service account used by your main EasyMorph Server, which is typically LocalService, has full permissions to access this .sqlite file and that the file is not being locked by some other process.

Great, this worked!

Thank you

One more quick question.

I see that my file path includes my personal user id (see attached image). If we have multiple people using this space will that cause problems down the road? In other words, should I move this to a centralized location?

It is possible that the service running EasyMorph server does not have access to your personal folder (AppData Local). By default, the EasyMorph Server runs under the built-in LocalService pseudouser, which has restricted access.