About EasyMorph Tutorials & Examples Web-help

Error: Array dimensions exceeded supported range

Hello,

This error appered when I tried to use a lookup transformation: first table have around 3.9 mil. rows and the second table, where the lookup is done, has around 89.5 mil. rows. Until now this transformation was working fine for long time ago but the tables are continues to grow but slowly. I check and I don’t found any wrong Cartesian product.

There is workaround but needs more than 4 tables.
There is a fix for this situation ?

Best regards,
Radu

same error also in a merge transformation. The looking up table is the same.

Hi Radu,

it seems like the lookup table starts hitting internal limitations in EasyMorph for number of rows per table. Try reducing the number of rows in the lookup table. For instance, try splitting the lookup table into two tables. Although, this will require doing lookup twice and merge twice.

Alternatively, if the lookup table is pulled from a database, you can try using the “Select matching DB rows” in order to pull only the subset of rows that is known to match your EasyMorph table.

To learn more about EasyMorph visit easymorph.com.