About EasyMorph Tutorials & Examples Web-help

Email connector does not allow to send email on behalf of other

I connected a newly established company mail to the Email connector in Easymorph and the test works. However, the goal is to send the email on behalf of one of my colleague which results currently in an error message.

The company mail that has rights to send on behalf of someone else. Can someone help and has tried the same?

I get the following Error message:
Failed to send test email: Transaction failed. The server response was: 5.20 StoreDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied;Failed to process message due to a permanent exception with message cannot submit message. …

Hello Kristian and welcome to the community!

Which connector you are using in EasyMorph - Email Server or Exchange Server?

Are you connecting to an on-premises email server or to a cloud-based email service like Exchange Online? In the latter case - which service you are using?

Have to tried to send a similar email (on behalf of a colleague) from a desktop email client like Microsoft Outlook?

Hey Andrew,

Thanks for your reply.

Currently, I use Email Server. In my company we have Office 365, so I would assume it is cloud-based, but I would need to ask IT for that.

No, I personally have not. But our IT department has apparently tested it and it should work.

Below a screenshot. Would it help to change some setting?

Kristian, is seems that in Office 365 permission to send emails on behalf of some other address should be explicitly granted in the setting of the latter address.

I was able to replicate this error and to solve it by adding my address to the “mail delegation” options of the other address in the Office 365 admin panel. Please refer to the following article for details: https://docs.microsoft.com/en-us/exchange/recipients-in-exchange-online/manage-permissions-for-recipients

Thanks for the helpful reply Andrew. I forwarded this to our IT department and hope that this will fix the error.

To learn more about EasyMorph visit easymorph.com.