About EasyMorph Tutorials & Examples Web-help

EM Server - Network Drive Not Found as the Space Public Folder


#1

Hi there,

I was trying to create a new space in the EasyMorph Server and point the public folder to a folder on on of the network drive. For some reason it gives me “Folder not found” error and stopped me from saving changes.

Whilst this network folder is indeed accessible through the Windows browser on that machine, and the machine have read/write access to that folder.

Can you please advise on this?

Thank you.
Ronnie


#2

Hi Ronnie,

In Windows, network folders are mapped every time when a user session is created. They are not mapped permanently. Therefore, after the Server [re]start network folders must be mapped explicitly.

There are 2 options to map a network folder:

  1. Run manually a project that maps necessary folders. Here is a sample project that does it: mount network drive.morph (4.4 KB)

  2. EM Server version 1.3 and up runs C:\Program Files\EasyMorph Server\systemscripts\onstart.cmd every time the Server service is starting. You can include the necessary mapping commands into that batch file so that the folders are mapped automatically.

PS. Moved the topic to #server category.


#3

Thank you Dmitry for pointing this out.

However, the network drive was mapped when I was working on the EM server. And I remapped the folder using the net use command in the EM project you provided but the server is still not seeing the folder. For example, it is currently mapped to M drive in windows while the EM server still gives error.

Additionally, I’ve tried entering the absolute path of the network folder (i.e. \{computer name}{folder}) but it still says not found.

Ronnie


#4

What account is the Server service running under – yours or the default one (NT Authority\LocalService)? If it’s the default account then what’s mapped under your account may be not accessible under the default account.


#5

That is exactly the problem. I forgot switching the account after installation.

Thank you very much for your help!
Ronnie


#6

You are welcome!