EM Server 5.4 : admin connection KO


Check the box of admin authentication in authentication page, type password, click log in => redirects to authentication page, connection not working. Nothing in the logs. We can not connect anymore as admin to the server web interface.

Hi Romain,

What browser do you use?

Are there errors in the browser console (opened by F12) when you press “Log in”?

We use the admin login every day. I wonder if the French locale could be an issue – we will check it.

I’m using Chrome. In the console I only see this issue, but we also have it in prod and it’s working fine :

A page or script is accessing at least one of navigator.userAgent , navigator.appVersion , and navigator.platform . Starting in Chrome 101, the amount of information available in the User Agent string will be reduced.

In the network tab I see this, and then it redirects to https://xxx/account/login?returnUrl=%2F


It may be related to this 302 thing which seems a warning code ? We don’t have that in prod.

Can it be related to a patch that you tried to apply because one day we said we had a load balancer in front of our servers and that login was not automatic but in 2 steps (first the welcome page, then we click on Login, no direct connection in our case).

Edit : we are testing in bench and in bench I was told there was no load balancer.
So now in bench in 5.4 we have :

  • still the problem that a direct URL to one space is not working and redirects us to the login page with 302 error
  • a new problem when we connect as admin => also sending a 302 error redirecting to the login page (infinite loop :slight_smile: )
    Note that when you connect to a space, the button is “Open” but when you connect as admin, it’s still “Login”. I prefer Login personnaly

The bug has been fixed. Please update your EasyMorph Server from our website. installed and the bug is still here, no difference :frowning:

Hmm… Just in case, I re-built and re-published the installer. Can you please download it from our website and try again.

Now it’s but nothing changes : still redirecting to the login page with 302 http code

Does redirecting happen before your press “Log in” or after?

After I press Login, it’s redirecting to the login page, without any message

We’ve fixed another bug and updated the Server installer. The bug appeared only when an AD space was selected. Can you please try the updated version?

Problem solved, thank you !

1 Like