EasyMorph model is erroring out when running excel macro

I created an EasyMorph model and tested it on my local machine before publishing to the server. The model works fine on my local machine but when I run the model from the server I get the generic:
The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

I was not sure how to get around that, so I made sure no excel processes are running, then opened the model on the Easymorph server and stepped through each action. All the actions worked as expected until I get to the run VBA macro action. It kicks off as normal then in about a minute or so, It flashes a window saying: File In use Personal.xlsb is locked for editing by EasyMorph, my only options are to click notify when available or cancel. This was not happening on my local machine when I ran it. Any advice?

Check out this topic: Running Excel Command on Server

Also, your post on a similar issue a while ago: EM server hangs when running powershell that runs excel macro

Also, check the following:

  • Excel application, installed on the server, is a 64-bit version and not a 32-bit
  • Your VBA macro doesn’t try to close the current workbook or the Excel application

Hello, EasyMorphNewbie.

Definitely check on Andrew’s items first.

Does the macro you’re triggering receive an argument from EasyMorph? (Have a thought for a workaround if you can’t get it sorted out.)