Does “Iterate Web request” has maximum URI length?

Does “Iterate Web request” has maximum URI length?

Url scheme is a part of url and looks like http:// or https:// . Check your weblocation connector and try to change Base url according to the api documentation.

length of the Path is 3125 and can be more than that. Is there any length limitation in easymorph?
FYI: It is working perfectly fine with less number fields(autogenerated). and the path is autogenerated string and working fine when it is run from powershell.

The length of an URL in EasyMorph is at least 65519 characters.

As @ckononenko mentioned, the error message indicates that the problem is not with the length of entire URL, it’s with the length of URL scheme.

A URL consists of several parts:

<Scheme>://<Host>:<Port>/<Path>?<Query>

For instance, in URL https://easymorph.com:443/index.html?someflag=1:

Scheme is https
Host is easymorph.com
Port is 443
Path is index.html
Query is someflag=1

So the error message says that the URL scheme is too long, which most probably means that the URL is composed incorrectly for some reason. Most probably, the base URL specified in the Web Location connector properties is incorrect. The base URL should be composed from at least a scheme and a host.

I see. Thanks. I used the URL parameter in Webrequest and looks like it started working.

Hello,

I’m getting an error message that states that the Uri string is too long:

image

The URI that triggered this error is approximately 75000 characters, can this be an issue? @dgudkov, what do you mean that the “the length of an URL in EasyMorph is at least 65519 characters”?

In the future I will need to send longer strings, as the API that I’m calling asks for all the information to be placed in URL parameters.

Thanks very much,

Roberto

Hi @roberto
The maximum length of an URI in WebRequest is 65519 characters.
Consider using the POST body instead of placing the values ​​in the uri.

I should’ve written “at most 65519 characters”.

Ok, thanks to both!