Data source name not found and no default driver specified

Does anyone help me on solving below error, “Data source name not found and no default driver specified”

Hi @dhananjaya and welcome to the Community!

Can you please share more details on that error? When does it appear? Maybe you post a screenshot of that error and the corresponding action or connector?

I would check 3 things :

  1. Names of ODBC must match exactly
  2. ODBC is 64 bits
  3. ODBC was added in the system tab rather than the user tab in the ODBC administration tool

Hi @RJO

I have a odbc bundle with both 32/64 bits still I am facing the same error.

Is it possible to share here the morph project ? It would be easier to understand the issue.

Hi @Maheshwar,

Please ensure that the DSN is created in the 64-bit version of ODBC Administrator.

Hi @andrew.rybka

Can you please elaborate how to create?

Hi @Maheshwar,

  1. Open the Windows start menu
  2. Type in ODBC
  3. Choose ODBC Administrator 64-bit
  4. Recreate the existing DSN or create a new one.

If that won’t help, please post screenshots of your ODBC connector settings and of the corresponding error message.

Hi @andrew.rybka

Thanks for the reply after following the above process still facing the below issue:

Your task is executed with a worker that is configured to work under the LOCAL SERVICE Windows account. That account only has access to System DSNs.

Please make sure that you created a System DSNs (and not a User DSN) on the computer that runs EasyMorph Server. And that you EasyMorph ODBC connector references that system DSN and not a User DSN with the same name.

As an alternative, if you really have to use User DSN, you can make the task to be executed under a user Windows account (by creating a new Worker and assigning that Worker to task’s space). The user account, specified in the new worker, should be that same account that was used to create the User DSN.

Hi @andrew.rybka

Can you share me any screenshots step by step how to do that or help me with any alternative as I never did these stuff previously.

Hi @andrew.rybka

I have created a system DSNs as you mentioned but the same error as below attached.

Hi @Maheshwar,

I sent an email to the address specified in your Community profile. Please check your inbox.