CSV export with timestamp

I currently setup an export to CSV format, but if I apply a parameter such as timestamp for the file name, it does not work, it exports as *.TXT format. Is there any special configuration in order to export as CSV?

Thank you very much.

Hi Jorge and welcome to the Community!

by default, when the file name has no extension, the “Export to delimited text” action automatically appends “.txt” to the file name. If you want the extension to be “.csv” just append it to the parameter that used for the export file name. To do this, you can use a calculated parameter that an expressions such as below:

[Timestamp] & '.csv'

Calculated parameters can be defined in the Parameter Editor, just like any other parameter.

**** moved to #uncategorized

Thank you, awesome product :slight_smile: btw.

This is great, saved my life, 1000 thanks,


Thank you :slight_smile: You’re welcome!