Convert Data Type - Text to Date with format of yyyy-M-d results in overflow

Hi Dmitry & crew,
I am trying to process a csv that contains 3.3M rows of data and I have to convert 7 text columns to dates and 6 of them work, but when I try to do the seventh I get “Added numbers are too big - results in overflow”. The column contains either a null or a date text value in the format of “yyyy-M-d” which is auto-detected correctly. Any help would be greatly appreciated.




Did you try to make a test on the null value to avoid converting the null cells, something like :
when(isempty([cell]) = false(), date([cell]))


Hi Keith,

How exactly do you convert the text values to dates? Can you post a screenshot of the expression or the settings of the action that you use for the conversion?

Hi Dmitry,

Here is the screen shot:

Hi Keith,

The most likely cause of the issue is invalid date value.
It must be in range from 01/01/0100 to 12/31/9999 to be correctly represented in OLE format that EM uses.
The fix could be to ensure that there are no values that are outside valid range.