Tutorials & Examples Web-help Blog

Connector '******' not found in shared connectors repository


#1

Hi everyone

I uploaded my morph project to the EM server but when i try to tun the job the server returns that it can’t find the connector.
While this connector is SHARED in the local project.

How can i solve this?

Kind regards
Pat


#2

“Shared” means that the connector is not stored in the project, but in a repository. Your local installation of EasyMorph has its own repository, and Server has its own – these are 2 different repositories. Therefore, you need to make sure that the Server repository also has a connector with the same name ‘******’ (although it may point to a different database).

You can see the path to the Server connector repository when you go to the Spaces page and click properties of a space. Note that each space can have its own repository of shared connectors.

To edit connectors in a Server repository just open the repository in the Connector Manager of desktop EasyMorph. It can be done even with the free edition of desktop EasyMorph.


#3

I am having the same issue. If I go into easymorph desktop and try to imbed the SQL connector in the project (and remove the shared), I get an error that tells me that the shared is missing. It’s like it does not see the embedded connector. Also, how do I “publish” a connector to the server?


#4

Hello Chris,

When you choose a connector in action’s properties, connecotr’s type (Shared or Embedded) is saved along with it’s name. And then connector is searched by the saved name among connectors of the saved type.

So when you move connector from Shared to Embedded (or vise versa), you have to re-select that connector in each action which were using the original connector.

As for publishing connectors to the server: embedded connectors are published with their projects, for shared connector you should upload shared connectors repository file to the server by yourself and then specify that file as “Repository” option in the settings of a space.


#5

That worked beautifully. Thank you so much!!