About EasyMorph Tutorials & Examples Web-help

Configuring the mail component fails


#1

When I try to configure the mail connector, it does not work to connect.

Could you please provide an example of how to set up such a connector (e.g. for outlook or Gmail)
When testing this it does not work;

I have tried:

server: smtp.gmail.com
account: my email
port 587 (TLS)

I am using the free version to test if easyMorph would fit for my purposes.


#2

Do you use 2-factor authorization for Gmail? If yes, then you will need to create a per-app password in your Google account and use it.


#3

Dear Dmitry,

I don’t use 2-factor authentication as far as I can see in my Gmail account settings.
I have retried on another network (outside the network of the company) and the problem persists. I have also tried two different encryption methods TLS on port 587 and SSL on port 465.

When I try to send the mail when configuring the email connector, it keeps throwing an error.

Could you please provide me some more information so that I can try again (with some screenshots)?

Thanks in advance !


#4

What error does it throw?

This works for a gmail I account I own:

image


#5

Thanks Dmitry.

That’s exactly the input I have inserted when I tested the connection.
Could it be that you need a special type of Gmail account for this or tweak some settings in Gmail itself? I am using a free Gmail account for testing.

Thanks in advance


#6

My Gmail account has a 2-factor authentication turned on, and I’m using a per-app generated password.

Maybe try a per-app password as well. See this article for more details: https://support.google.com/accounts/answer/185833?hl=en


#7

Hi,

Some weeks ago, it worked with my Gmail account using
server: smtp.gmail.com
account: my email
port 587 (SSL)

It’s not working anymore…
Something have changed?

Michel

PS: it works now only with the following configuration (no encryption :frowning:) :


#8

If you are not using per-app passwords, then you may need to enable less secure apps at: https://myaccount.google.com/lesssecureapps