Can't suppress warning

this is driving me crazy!
I've built a mechanism in my easymorph project to send a mail if certain error cases are present, and if so to exclude the codes of the error cases from further processing.

If the input data is correct, there are no error cases.

To determine, in the overall execution, if some of my data lines correspond to an error case, I use a merge table action, matching the data line code to the error case code.

So, if all is well, no errors, this merge should not produce any data, all merged columns should be empty.

So far so good, but I get a warning every time I execute an action beyond this merge.

I've tried suppressing the warnings for the merge action, saved the project, closed the project and reopened it, re-executed just the merge action and taken it from there, .... all to no avail.

this is very frustrating, everytime I test something I have to click away a warning that should be suppressed.

Hi Dirk,

This is a known issue, and yes, it's annoying. Just to clarify - did you try to suppress the working using the setting below?


hello Dmitry,

thank you for the swift reply!
Yes, I did try to suppress the warning with the setting in your screenshot.

I managed to work around it, by adding a dummy row in both tables with matching values in the merge comparison columns, so that the merge always gets at least one hit, and thus gives no warning. After the merge I delete the resulting row so no harm done. ( I literally put the value "bullshit code" in both tables for this dummy row, something I'm sure will never naturally appear in either table .... :slight_smile: )

So it's possible to avoid it, but highly inefficient and annoying.

That should have worked. What EasyMorph version are you using?

Try updating EasyMorph to the most recent version. Suppressing warnings should work.